Grandstream GXP 1630
Grandstream GXP 1630

Grandstream GXP 1630

0/50
0 reviews Write a review
  • Brand: Grandstream
  • Product Code: GXP1630
  • Availability: Out Of Stock
  • £62.40
  • Ex VAT: £52.00

VoiceHost no longer endorses Grandstream Phones, however please follow the link below for our recommended phones -

https://store.voicehost.co.uk/snom


NOTE: A Power Supply (UK PSU) is included with this phone.

A high-end IP phone for small business users, the GXP1630 delivers a suite of powerful VoIP features in an easy-to-use fashion with a modern design. The GXP1630 offers support for up to 3 lines and features Gigabit ports to maximize connection speeds and call quality. The phone includes 8 BLF/speed dial keys that allows users to easily monitor presence and status of other extensions and transfer calls. Additional features include HD audio for crystal-clear calls, 4-way conferencing to maximize productivity, 3 XML programmable soft keys for customization, EHS support for Plantronics headsets and integrated PoE to allow one cord to power the phone and give it a network connection. These features and more allow the GXP1630 to be a high-quality and versatile small business IP phone

As all Grandstream IP phones do, the GXP1630 features state-of-the-art security encryption technology (SRTP and TLS). The GXP1630 supports a variety of automated provisioning options, including zero-configuration with Grandstream’s UCM series IP PBXs, encrypted XML files and TR-069, to make mass deployment extremely easy.

Features:
3 SIP accounts, 3 line keys, 4-way conferencing, 3 XML programmable context-sensitive soft keys
HD audio on speakerphone and handset
Dual-switched Gigabit ports, integrated PoE
8 dual-colored BLF/speed dial keys
EHS support for Plantronics headsets
Up to 500 contacts, call history up to 200 records


    Write a review

    Please login or register to review


    Your go everywhere office...

    iOS CompatibilityiOS 8.0 or above (Compatible with iPhone, iPad, and iPod touch)
    Android CompatibilityGingerbread 2.3.3 or above





    Learn more